maestra - Flows – Incident details

All systems operational

Flows

Resolved
Degraded performance
Started 26 days agoLasted about 6 hours

Affected

Admin panel

Operational from 10:40 AM to 5:01 PM

Site personalization

Operational from 10:40 AM to 5:01 PM

Loyalty

Operational from 10:40 AM to 5:01 PM

Mass campaigns

Operational from 10:40 AM to 5:01 PM

Transactional messages

Degraded performance from 10:40 AM to 1:39 PM, Operational from 1:39 PM to 5:01 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    The fix has been rolled out: new flow transactions are no longer hanging on step execution. We are now assessing the transactions that got stuck during the incident window and will recover them where possible; affected flows may still show delayed or incomplete steps for now.

  • Identified
    UTC
    Identified

    Some flows may hang at a step execution: up to 10% of flow transactions passing operation or webhook steps are currently affected.

    We have identified the cause and are working on a fix. We will post an update as soon as the issue is resolved.