maestra - Platform outage – Incident details

All systems operational

Platform outage

Resolved
Partial outage
Started 2 months agoLasted 43 minutes

Affected

Admin panel

Major outage from 2:39 PM to 3:22 PM

Site personalization

Major outage from 2:39 PM to 3:22 PM

Loyalty

Major outage from 2:39 PM to 3:22 PM

Mass campaigns

Major outage from 2:39 PM to 3:22 PM

Updates
  • Postmortem
    Postmortem

    Due to a configuration error, offsite backup uploads fully saturated the network link, causing the gateway to become unavailable. To prevent this from happening again, we introduced rate limiting and moved backup transfers to a private Direct Connect to S3 instead of the production link.

  • Resolved
    Resolved
    This incident has been resolved. We will provide a comprehensive report next week.
  • Identified
    Identified

    The platform is experiencing outages. The admin panel and some functionality are affected. We are actively investigating the issue.