maestra - Degraded performance of CDP – Incident details

All systems operational

Degraded performance of CDP

Resolved
Degraded performance
Started 2 months agoLasted about 8 hours

Affected

Admin panel

Degraded performance from 2:15 AM to 9:55 AM

Site personalization

Degraded performance from 2:15 AM to 9:55 AM

Loyalty

Degraded performance from 2:15 AM to 9:55 AM

Mass campaigns

Degraded performance from 2:15 AM to 9:55 AM

Transactional messages

Degraded performance from 2:15 AM to 9:55 AM

Updates
  • Resolved
    UTC
    Resolved

    The issue was caused by elevated memory usage on part of our infrastructure, with the largest impact around 02:00 and 06:00 UTC. Service has been fully restored since approximately 08:30 UTC. We are reviewing the root cause and will take steps to prevent a recurrence.

  • Identified
    UTC
    Identified

    The UI panel may be slow or unresponsive. 2FA codes may be delayed. Synchronous integrations may experience transient errors.

    We've identified the root cause and are working on a hotfix.