maestra - Transactional flow messages delayed – Incident details

All systems operational

Transactional flow messages delayed

Resolved
Partial outage
Started 5 days agoLasted about 1 hour

Affected

Transactional messages

Major outage from 3:45 PM to 4:30 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    Impact: For a period, transactional messages triggered by flows were delayed. Messages were accepted and queued as normal but were not processed on time.

    Status: Resolved. Processing has resumed and the backlog has been cleared.

    Follow-up: We're reviewing the cause and why our monitoring was slow to flag the issue.